Всё для Учёбы — студенческий файлообменник
1 монета
docx

Контрольная «Решение систем уравнений» по Информационным системам (Шмелев В. В.)

Задача № 1

Постановка задачи:

Решить систему уравнений вида АХ=В и выполнить проверку решения.

9 5 4 7

А= 4 6 8 7

5 8 7 6 5 6 8 7

0 В= 6 3

7 Первый способ: решение с помощью обратной матрицы

1. Открываем Microsoft Excel, в ячейку А3 вводим "матрица А". Затем начиная с ячейки В5 до Е8 вводим данные матрицы А.

2. В ячейке G3 вводим "вектор-столбец В". Затем начиная с ячейки G5 по G8 вводим данные матрицы В.

3. Находим определитель матрицы А:

* в ячейку В11 вводим

=МОПРЕД(массив), затем Enter.

4. Находим обратную матрицу (в ячейке G13 вводим "обратная матрица ")13 вводим "Х=енных хода отображены на рис. ываем функцию пользователя для вычисления будущей суммы вклада:

Function_НакопДолг (ВелКред,СрокКред,Ставка)

НакопДолг = ВелКред*((1+Ставка)*(СрокКред/12))

Отладим программу:

* вызываем редактор Visual Basic:

Сервис > макрос > редактор Visual Basic;

* для создания функции НакопДолг необходимо зайти в модуль:

Insert > Module, набираем программу в окне модуля I > сохраняем (этот ход отображен на рис. 16);

* откомпелируем программу:

Debug > Compile VBA Project > сохраняем > File > Close and Return to Microsoft Excel;

* в ячейке F4 вводим:

= НакопДолг (диапазон) > Enter.

Рис. 16

Задача № 10

Постановка задачи:

Рассчитать все пустые ячейки голубого цвета, изображенные на рис. 17.

Рис. 17

Решение:

1. Рядом с таблицей создаем еще одну таблицу, в которой определим тип данных:

* в ячейке I3 вводим:

=ТИП(B3) > Enter > аналогично определяем тип данных в оставшихся ячейках.

2. Найдем количество пустых ячеек:

* в ячейке В12 вводим:

=СЧИТАТЬПУСТОТЫ(В3:В9) > Enter > протягиваем маркер до ячейки G12.

3. Найдем количество непустых ячеек:

* в ячейке В10 вводим:

=ЧСТРОК(В3:В9)-В12 > Enter > протягиваем маркер до ячейки G10.

4. Найдем количество ячеек с текстом:

* в ячейке В14 вводим:

=СЧЁТЕСЛИ(I3:I9;"2") > Enter > протягиваем маркер до ячейки G14.

5. Найдем количество чисел:

* в ячейке В16 вводим:

=СЧЁТЕСЛИ(I3:I9;"1") > Enter > протягиваем маркер до ячейки G16.

6. Найдем сумму чисел:

* в ячейке В18 вводим:

=СУММ(В3:В9) > Enter > протягиваем маркер до ячейки G18.

7. Найдем среднее значение чисел:

* в ячейке В20 вводим:

=В18/В16 > Enter > протягиваем маркер до ячейки G20.

Решение задачи № 11 отображено на рис. 18.

Рис. 18

Задача № 11

Клиент в течении 5 лет в начале каждого месяца делает вклады в банк. Годовая ставка по выбоанному виду вклада равна 10%. Рассчитать сумму платежа, чтобы в конце 5 года на счету клиента была сумма равная 14 000.

Решение: В Microsoft Excel выделяем ячейку А1 > вставка > функция > категория > финансовые > OK > ППЛАТ > OK > в окне "аргументы функции" в строку "ставка" вводим 10 > "кпер" вводим 5 > "Нз" вводим 10000 > "БС" вводим 14000 > "Тип" вводим 0 > OK.

Заполнение окна "аргументы функции" отображено на рис. 19.

. Рис. 19

Показать полностью…
Похожие документы в приложении